Some slowness is observed on the platform. Our teams are working on resolving this anomaly.

Incident Report for Product-Live Status Next Gen

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 19:21 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 09:48 CET

Investigating

Our teams have detected an incident that may affect the loading of images and the platform.
Investigations are underway, and we will keep you informed.
Posted Oct 29, 2025 - 17:52 CET