Some slowness is observed on the platform. Our teams are working on resolving this anomaly.
Incident Report for Product-Live Status Next Gen
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 18:59 CET
Investigating
Some slowness is observed on the platform
Posted Oct 24, 2023 - 17:16 CEST